Ver los errores del aprovisionamiento automático

Cuando configures el aprovisionamiento automático de tus aplicaciones basadas en SAML, es posible que aparezcan estos errores:

Lee la información que se proporciona a continuación sobre cómo depurar y resolver estos errores.

Nota: Si no puedes resolver un error siguiendo los pasos que se indican aquí, ponte en contacto con el servicio de Asistencia.

Errores en el tiempo de configuración

Error de código de autorización

Este error se mostrará cuando el código de autorización no se pueda intercambiar por un token de actualización. Esto puede suceder si el código de autorización es incorrecto o si esperas demasiado tiempo para hacer clic en Guardar cambios después de realizar la autorización. El error debería resolverse realizando la autorización de nuevo y guardando los cambios.

Mensaje de error Solución
No se ha podido generar el token de autorización. Prueba de nuevo la autorización y vuelve a guardar los cambios.

Errores de página inactiva

Los errores de página inactiva se producen cuando la página del navegador del usuario no se ha actualizado y ha habido algún cambio en la configuración fuera de la sesión actual (ya sea en otra ventana del navegador o por parte de un usuario distinto). Estos son los errores asociados que se pueden mostrar:

Mensaje de error Solución
Tu página está inactiva. Existe una configuración de aprovisionamiento. Actualiza la página para anular la configuración actual.
Tu página está inactiva. No existe una configuración de aprovisionamiento. Actualiza la página para anular la configuración actual.
Tu página está inactiva. No se puede activar una configuración de aprovisionamiento que aún no se ha establecido. Actualiza la página para anular la configuración actual.
Tu página está inactiva. No se puede eliminar una configuración de aprovisionamiento que aún no se ha establecido. Actualiza la página para anular la configuración actual.

 

Errores de página transitorios

Estos errores son transitorios y deberían resolverse al actualizar la página o al volver a intentar la acción después de un tiempo. 

Mensaje de error Solución
No se ha podido obtener la configuración de aprovisionamiento  Actualiza la página. 
No se ha podido obtener la configuración anterior de aprovisionamiento Actualiza la página. 
No se ha podido obtener el estado de aprovisionamiento Actualiza la página.
No se ha podido activar el aprovisionamiento Vuelve a intentar activar el aprovisionamiento.
Se ha producido un error al eliminar la configuración de aprovisionamiento Vuelve a intentar eliminar la configuración.
No se ha podido establecer la configuración de aprovisionamiento Crea la configuración de aprovisionamiento de nuevo y guarda los cambios.
No se ha podido actualizar la configuración de aprovisionamiento Actualiza la configuración de aprovisionamiento de nuevo y guarda los cambios.
No se han podido obtener atributos personalizados Vuelve a intentar guardar los atributos personalizados.
No se ha podido actualizar la asignación de atributos Actualiza la asignación de atributos de nuevo.
No se ha podido actualizar la configuración de grupo para el aprovisionamiento de cuentas Actualiza la configuración de grupo de nuevo.
No se ha podido actualizar la configuración para dar de baja las cuentas Actualiza la configuración para dar de baja las cuentas de nuevo.
Se ha eliminado correctamente la configuración, pero no se ha podido revocar el acceso de cliente API

Al eliminar la configuración, se revocan los permisos que la aplicación necesita para acceder a tus datos almacenados en Google.

Si se produce un error por algún motivo, accede a la página Administrar el acceso de clientes API en la sección Seguridad para revocar manualmente el acceso.

Si has eliminado la configuración y tu intención es volver a establecerla, no es necesario que realices ninguna acción. 

Se ha producido un error al actualizar la configuración de aprovisionamiento Actualiza la página. 
Error de autenticación Las credenciales de autenticación (el token de portador, por ejemplo) indicadas en la configuración son incorrectas. Escribe las credenciales correctas.
La URL de SCIM que has especificado no es válida El punto final de destino no era válido. Escribe la dirección URL correcta.
Se ha producido un error al habilitar el aprovisionamiento Mueve el control deslizante Aprovisionamiento automático a Activo
Se ha producido un error al eliminar la configuración de aprovisionamiento
  1. Haz clic en Aprovisionamiento automático para abrir Configuración.
  2. En Eliminar configuración, haz clic en Eliminar
No se han podido obtener los atributos del proveedor de servicios de destino
  1. Haz clic en Aprovisionamiento automático para abrir Configuración.
  2. En Asignación de atributos, haz clic en Editar.
  3. Edita las asignaciones del proveedor de servicios según sea necesario.
No se ha podido obtener el esquema de recurso de destino Revisa la URL del punto de conexión indicada durante la configuración del aprovisionamiento automático y vuelve a intentar asignar atributos de Cloud Directory a los atributos de la aplicación de destino.

Errores en el tiempo de ejecución del aprovisionamiento automático

Los errores en el tiempo de ejecución del aprovisionamiento automático se pueden deber a problemas de acceso, autorización o configuración de la API.

Errores de los servicios internos de Google

Código de error Descripción y solución
17003
17006
17008

Descripción: 

No se ha podido autenticar con los servicios internos de Google.

Motivo:

Se han revocado los permisos de este ID de cliente de aprovisionamiento de usuarios:

910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Solución: 

Asegúrate de que este ID tiene los siguientes permisos:

https://googleapis.com/auth/admin.directory.user.readonly,
https://googleapis.com/auth/admin.directory.userschema.readonly,
https://googleapis.com/auth/admin.directory.group.member.readonly

En la consola de administración, utiliza la opción Administrar el acceso de clientes API de Seguridad > Configuración avanzada para comprobar si el ID de cliente tiene estos permisos o para añadírselos.

17007

Descripción:

No se ha podido conceder acceso a las aplicaciones que admiten el aprovisionamiento automático mediante la autorización de delegación en todo el dominio.

No se ha podido conceder la autorización de delegación en todo el dominio al servicio de aprovisionamiento automático. Esto resulta esencial para que el servicio pueda leer el directorio de Google.

Motivos:

Motivo 1: se han revocado los permisos del ID de cliente de aprovisionamiento de usuarios.

Soluciones:

En la consola de administración, accede a Administrar el acceso de clientes API en Seguridad > Configuración avanzada para añadir los siguientes ID de cliente y permisos:

ID de cliente:
910835873219-es01p47a1ks618hgp59q26cnc6sv33r3.apps.googleusercontent.com

Permisos:

https://googleapis.com/auth/admin.directory.user.readonly,
https://googleapis.com/auth/admin.directory.userschema.readonly,
https://googleapis.com/auth/admin.directory.group.member.readonly

También puedes eliminar la aplicación en cuestión y volver a añadirla.

Motivo 2: errores inesperados del sistema

Solución:

En la mayoría de los casos, este error se resolverá automáticamente. Sin embargo, si no se ha resuelto después de unas horas, puedes añadir el ID de cliente y los permisos, o bien eliminar y volver a añadir la aplicación, como se ha indicado en el motivo 1 anterior.

Errores de token de autenticación

Código de error Descripción y motivo Solución
17010

No hay credenciales suficientes para llamar a tu URL de SCIM.

Motivo: el token de autorización se ha revocado.

Prueba a autorizarlo otra vez. Para ello, haz clic en Aprovisionamiento automático para abrir Configuración y, a continuación, haz clic en Volver a autorizar.
17013

No se ha podido recibir un token de acceso de tu proveedor de servicios.

Motivo: el token de autorización se ha revocado.

Si el error no se resuelve automáticamente al cabo de un tiempo, prueba a autorizarlo otra vez. Para ello, haz clic en Aprovisionamiento automático para abrir Configuración y, después, haz clic en Volver a autorizar.

Errores de token de acceso

Código de error Descripción y motivo Solución
17002
17011

No se ha podido generar un token de acceso.

Motivo: algunos servicios internos de Google no están disponibles en ese momento.

Este error se debería resolver de forma automática después de un tiempo.
17009 No se ha podido generar el token de acceso a partir del token de actualización. Prueba a autorizarlo otra vez. Para ello, haz clic en Aprovisionamiento automático para abrir Configuración y, a continuación, haz clic en Volver a autorizar.

Errores generales

Código de error Descripción y motivo Solución
1200x

Error interno

Este error se debería resolver de forma automática después de un tiempo.
25001 Backend/servicio de Google no disponible temporalmente. Configura otra vez el aprovisionamiento automático.
25002

Backend/servicio de Google no disponible temporalmente. 

Motivo: la aplicación no está instalada para el cliente.

Instala la aplicación y vuelve a configurar el aprovisionamiento automático.
25005 Backend/servicio de Google no disponible temporalmente. Este error se debería resolver de forma automática después de un tiempo.
25016 Backend/servicio de Google no disponible temporalmente. Configura otra vez el aprovisionamiento automático.
50001 Error interno Este error se debería resolver de forma automática después de un tiempo.
50003 Error interno Este error se debería resolver de forma automática después de un tiempo.
50005 Un grupo eliminado está presente en los filtros de grupos configurados. Quita el grupo eliminado de la configuración del ámbito del aprovisionamiento.
50006 Error interno Este error se debería resolver de forma automática después de un tiempo. 

Errores en el nivel de recursos

Si la sección Aprovisionamiento automático de la página de configuración de la aplicación SAML muestra Errores, haz clic en Descargar lista. El archivo descargado incluye las acciones de creación, eliminación o actualización que han fallado, así como un código y una descripción para cada error.

Estos errores solo afectan a los recursos especificados en el archivo. 

Código de error Descripción del error Solución
45003

La aplicación basada en SCIM no acepta la solicitud de actualización, creación o eliminación de recursos. Examina los detalles del error en el archivo de errores descargado.

Posibles motivos:

  1. Se ha superado el límite de licencias. Tienes licencias para crear solo cinco usuarios en la aplicación basada en SCIM y has activado el aprovisionamiento automático para seis usuarios.
  2. Valor demasiado largo. El valor proporcionado, por ejemplo, el ID de correo electrónico, es demasiado largo y la aplicación basada en SCIM no lo acepta.
  3. Debes tener como mínimo una autorización. Además, una de las autorizaciones debe ser el ID de perfil.
  4. El nombre de usuario ya existe. Debe ser único en toda la organización.
  5. No se encuentra el recurso (usuario) en el proveedor de servicios.
  6. El valor de ID de usuario de SCIM no es válido.
Corrige el error, guarda los cambios y vuelve a intentarlo.
45004

Se ha producido un error entre el proveedor de servicios y Google como proveedor de identidades. El texto del error es "Internal error - Quota Exceeded" (Error interno: cuota superada).

Posibles motivos:

  • Se ha producido una interrupción que afecta al proveedor de servicios.
  • El servidor del proveedor de servicios no está operativo.
Ponte en contacto con el proveedor de servicios.
45005 No se puede acceder a la URL de SCIM que has configurado. Comprueba la URL de SCIM proporcionada en la consola de administración. Corrige el error, guarda los cambios y vuelve a intentarlo.
45006

La aplicación basada en SCIM no acepta la solicitud de actualización, creación o eliminación de recursos o no se creó correctamente. Examina los detalles del error en el archivo de errores descargado.

Posibles motivos:

  1. Valor demasiado largo
  2. Licencias insuficientes
  3. Licencia no válida
  4. No existe valor de autorización
Corrige el error, guarda los cambios y vuelve a intentarlo.
45016

La aplicación basada en SCIM no ha aceptado tu solicitud para actualizar, crear o eliminar un recurso porque has dejado en blanco un campo obligatorio. Examina los detalles del error en el archivo de errores descargado.

Corrige el error, guarda los cambios y vuelve a intentarlo.

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